OP3-like project, using Pi4, OpenCR, rplidar, dynamixels. USB communication issues between Pi and OpenCR

Hi there,
I am in the middle of this biped project. I’m using a Pi4, OpenCR, dynamixels and rplidar.
I have Raspian on Pi4, and downloaded and catkin_make the OP3 code and rplidar code in my workspace. (ROS melodic)
I have compiled and uploaded the OP3 code to the OpenCR directly from my windows desktop.
I have successfully launched the rplidar, including SLAM on the Pi4 and it began building the map.
I have more work to do on that, but it works.
I have been able to SSH into the Pi4 from the desktop, and roslaunch the rplidar and rosrun rviz on the desktop and create the map that way as well.
My problems start when trying to roslaunch op3_bringup op3_bringup.launch as shown in the op3 tutorials.
I have updated a number of modules to fit my biped including those which mention device pertaining to opencr. /dev/ACM0 in my case.
Also, my first 20 dynamixels mimic OP3. But I do have 6 more and added those accordingly throughout the modules/files.
My error messages are just like this guy from 2+ years ago…but I guess he has a NUC.

[ERROR] [1532100652.615660890]: Torque on DXLs! [[RxPacketError] Unknown error code!]
[ERROR] [1532100652.651648647]: Torque on DXLs! [[RxPacketError] Unknown error code!]
[ERROR] [1532100652.687631622]: Torque on DXLs! [[RxPacketError] Unknown error code!]
[ERROR] [1532100652.723618992]: Torque on DXLs! [[RxPacketError] Unknown error code!]
[ERROR] [1532100652.759606870]: Torque on DXLs! [[RxPacketError] Unknown error code!]
[ERROR] [1532100652.895751751]: Fail to control LED [[RxPacketError] Unknown error code!]
[ERROR] [1532100655.314481806]: [RobotisController] first bulk read fail!!
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::lock_error >'

The problem is, I have a Pi4. How do I add the OP3 hidden network to a Pi4 from:

Thanks in advance for any ideas or help,
Jay

Hi Jay,
This has been responded in the OP3 repository issue thread.
Please see below.


Thanks!