SBC wifi problem with Melodic

I have confiured network as described in 3.2.3 Configure the Raspberry Pi (MELODIC).
Wifi configuration works only once. After rebooting SBC is not connecting WIFI again.
Configuration is file /etc/netplan/50-cloud-init.yaml seems to be ignored.
Problem stays even when I write network: {config: disabled} file to /etc/cloud/cloud.cfg/99-disable-network-config.cfg.

Thanks for advice
Udo

Hi @Udo_Michelfelder
I’ll share the Melodic recovery image for RPi 3B+ with you.
Preparing the image will take a couple (working) days.
In the meantime, could you check if you have any other file in the netplan directory that could override the network setting?
Also, in some cases, setting a country code for wifi could help resolving the issue.

Hello Will,

my linux skills are limited, so I am not shure if I can help you much in this regard.
Just for your information I discovered a similar problem when I was trying to upgrade my Jackal (Clearpath) from Kinetic to Melodic (i386 PC).
For now my solution on the Jackal is using a Jetson Nano, here it was no problem to get Melodic up and running.
For my TB3 waffle with openmanipulator I will stay with Kinetic til Melodic gets supported for both TB3 and openmanipulator. ROS2 would be an option too.
Do you have any plans to support Jetson Nano with TB3 waffle? I would like to use a 3D cam such as the ZED2 or OAKD and think that Jetson Nano would be a advantage.

Best Regards

Udo

Udo,
I understood. Hopefully sharing the recovery image will relieve agony in SBC setup procedure.
We do have plans for upgrading TurtleBot3, but I cannot disclose further information at this time.
But I can say that it will be beneficial to many ROS users as well as TurtleBot3 customers.
Thanks!